Portland Bike Forums (by BikePortland.org)

Go Back   Portland Bike Forums (by BikePortland.org) > General Discussion > Tips & Advice
Register FAQ Members List Calendar Search Today's Posts Mark Forums Read

Reply
 
Thread Tools Display Modes
  #1  
Old 05-31-2013, 09:15 AM
pdxdanc pdxdanc is offline
Junior Member
Site Admin
 
Join Date: Nov 2007
Posts: 7
Default Broken ultegra shifter - help!

Wasn't sure whether to post this in the newbie forum (looked like a bit of a ghost town), or here. I have a 2003 Lemond Buenos Aires. The left (i.e. front) shifter has stopped working. Since this is a triple, and 9 speed Ultegra, I'm a bit lost as to the correct replacement shifter, or which newer shifter might work. Is it a 6500? 6603? Will a 6603/6703 work? What's a good resource to get a replacement?

Thanks!
Reply With Quote
  #2  
Old 05-31-2013, 11:57 AM
RonC's Avatar
RonC RonC is offline
Senior Member
Site Admin
 
Join Date: May 2009
Location: Lake Oswego
Posts: 136
Default

Before you replace, look for a simple fix first. Bathe the inside of the shifter mechanism with liberally applied WD40. Let it sit, then re-apply. Then try shifting again. Sometimes these things just get gummed up and need a little coaxing.

Also, check the cable. A frayed cable can get stuck in the works and all shifting comes to a halt. You will probably have to take the cable off to see if this is the problem. If small pieces of frayed cable are stuck in there, you may need some good tweezers to pull them out.

Hope its a simple fix. Otherwise you will need a new shifter. I think it would be a 6503 to match, either NOS or used if you can find it. I thing the 6603 or 6703 would probably work too, but I'm not an expert on that. You could also put a downtube or bar-end shifter on if you wanted to try something a bit different.

Good luck!
Reply With Quote
Reply

Tags
shifters, ultegra

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -8. The time now is 03:48 PM.




A production of Pedaltown Media Inc. / BikePortland.org
Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.